Winthrop University: Online Learning - System Requirements

We are here to help you!
Winthrop's admissions team is ready and available to help you. If you have any questions, there are three ways you can contact us:
Phone: 803/323-2191
Email: Admissions@winthrop.edu
Virtual Chat: Click here to register

For updates, announcements and special messages from Admissions, please follow us on Instagram - @winthropadmissions

Also, please see our FAQs for prospective students and families amid Covid-19.

Online Learning

System Requirements


Blackboard Learn 

If your computer does not meet the minimum system requirements, Blackboard and other integrated software may not function properly. Prior to using Blackboard on your computer, compare your current system configuration with the minimum recommended system requirements below. Please note that Chromebooks and the Linux operating system are not compatible with Respondus Lockdown Browser.


Processor
1 GHz or more

Ram
2 GB or more

Hard Drive
40 GB or more

Hard Disk Space Available
20 GB

Internet Connection

Broadband high-speed Internet access

5 Mbps download speed

Run a speed test to make sure your download speed meets this requirement.

Adapter for Ethernet connection (LAN), or a wireless adapter (Wi-Fi)

Other
Sound card and speakers

Accessibility

Blackboard strives to make all its products as accessible as possible. The two most recent versions of JAWS are used during accessibility testing.

Additional Software and Hardware

The following software or hardware may be required for specific courses that you are taking, such as courses that require Respondus Lockdown Browser for online tests or participation in meetings via a web conferencing platform. Please note that Chromebooks and the Linux operating system are not compatible with Respondus Lockdown Browser.

  • Microsoft Office Word, Excel, and PowerPoint

  • Windows Media Player (Windows Only), QuickTime (Mac only)

  • Webcam (built-in or standalone)

  • Microphone (built-in, standalone, or headset)


Browser Checker Tool

Run the Blackboard browser checker tool to make sure that your browser has the necessary specifications for using Blackboard.

Browser Configuration

Your browser must be configured properly as follows:

  • JavaScript must be enabled.

  • Cookies must be enabled.

  • Pop-up windows must be enabled.

Browser Plug-ins

At a minimum, you will need three browser plug-ins to use Blackboard Learn: Adobe Reader, Adobe Flash Player, and the latest version of Sun JRE 7 - Java Runtime Environment plug-in. Blackboard Learn will not run properly if you are using an incompatible version of Java or if you have multiple versions of Java installed. (You may need additional plug-ins if the course you are taking includes multimedia elements.)

To download and install the current versions of Adobe Reader, Adobe Flash Player, and the Java plug-in.

    1. Adobe Reader

    2. Adobe Flash Player

    3. Get the Java plug-in and also be sure to remove any older versions of the Java plug-in.

Note: On OS X 10.8+, Java is no longer shipped as part of the OS install and must be downloaded and installed by users on request of application/applet. This is a one time action on the part of the user.


Supported Operating Systems and Browsers

Operating System Versions

  • Windows: 7, 8, 10
  • Mac: OS X 10.12 or later

Browser Versions

  • Chrome: 63+
  • Firefox: 57+
  • Safari: 12+


Unsupported Technologies

  • Chromebooks and the Linux operating system are not compatible with Respondus Lockdown Browser.
  • Windows XP
  • Internet Explorer
  • Chrome versions below 63
  • Firefox versions below 57
  • Safari versions below 12 (or any version on Windows).
  • Mac OSX versions below 10.12
  • JRE 5, 6

If the computer you are using has a compatible browser, you still may be able to use parts of Blackboard Learn. However, you may also experience problems, especially when completing quizzes and tests or using chat and the Virtual Classroom. For the best performance, please use a certified browser and operating system when using Blackboard.

Blackboard Learn requires that your Web browser conforms to certain standards. If you have an out-of-date or unsupported browser, you will need to download either a certified version of your current browser or a different certified browser before attempting to log into Blackboard Learn.

Last Updated: 6/2/20